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Creating ePubs

 by Sandee Cohen

from InDesign

You can use the EPUB tools in InDesign CS5.5 to turn 
your print layouts into digital publications to view 
on an iPad or Kindle.
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On May 19, 2011 Amazon.com announced the 
following:

“Amazon began selling hardcover and paper-
back books in July 1995. Twelve years later in 
November 2007, Amazon introduced the revolution-
ary Kindle and began selling Kindle books... Today, 
less than four years after introducing Kindle books, 
Amazon.com customers are now purchasing more 
Kindle books than all print books—hardcover and 
paperback—combined.” 

That doesn’t mean Kindle books or even all 
forms of ebooks are outselling print books every-
where. With no physical brick-and-mortar stores, 
Amazon’s ebook sales can easily outpace the sales 
for physical books.

Still, ebooks are the wave of the future. If you 
design books and haven’t yet created an EPUB, 
you’re already behind the curve. But don’t worry! 
This article will get you up to speed in a hurry.

The first step is to upgrade to InDesign CS5.5, 
if you don’t already have it. The EPUB advances in 
CS5.5 are so important that anyone serious about 
using InDesign to create ePubs can justify the cost.

Now let’s get into the basics you need to know 
to create a simple EPUB from a layout originally 
designed for a print publication. Note that I said 
“basics.” Creating EPUBs is a deep and rich topic, 
and—especially because the standard is changing 
and functions differently on different devices—
requires constant re-education. However, if you’re 
curious about EPUB and want to put your toe in the 
water, this should get you started!

Understanding EPUB Limitations
Think of ePubs as little websites enclosed in a special 
wrapper. Inside are files such as HTML documents, 
fonts, and images that make up the content and lay-
out for the book. Also inside is CSS (cascading style 
sheets) that define the text formatting, and other 
scary XML-flavored files (like toc.ncx and content.
opf ) that act as middle managers to keep everything 
in order. Fortunately, you don’t have to worry about 
those very often when you’re just getting started.

InDesign layouts are designed for print. So ePubs 
created from InDesign rarely reflect the original 
print layout. In fact, most of what you do during the 
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formatting and export of EPUB documents 
has to do with changing the print-centric 
layout of file into an HTML-based layout. In 
other words, when it comes to EPUB, you can 
ignore most of what you’ve learned about 
laying out books in InDesign, especially the 
stuff about designing a page. An EPUB is 
much closer to a Microsoft Word document—
it’s a linear flow of text and graphics.

Exporting and Previewing the EPUB
The best way to understand what happens 
during the print-to-EPUB workflow is to cre-
ate and examine an EPUB document. For the 
purpose of this article, let’s pretend we’re 
working with a text-only novel.

Choose File > Export, name the file, 
choose a location, and then choose EPUB 
from the Format menu. A dialog box appears. 
There are three areas in the dialog box: 
General, Images, and Content (Figure 1). 
Since this EPUB won’t have any images, only 
the General and Content options are relevant.

I’ll get into the options in each section 
later. For now, just make sure View EPUB after 
Exporting is chosen and click OK. The EPUB 
opens in Adobe Digital Editions, Adobe’s 
desktop ebook reader.

Use Digital Editions to see how the EPUB 
you created differs from the original InDesign 
file. You’ll have to live with some differences; 
others can be controlled before you export 
the document. It is controlling these differ-
ences that are the refinements that separate 
the ordinary EPUB from the sophisticated 
one. Note that viewing the EPUB through 
Digital Editions is only an approximation. 
There are many viewers, and each may be 
slightly different; for example, there are many 
things, such as embedded video, that work in 
EPUB on an iBook, but which are completely 
ignored by ADE. You must view the EPUB on 
an actual device to be sure what readers with 
that device will see.

Line Breaks. In the Digital Editions pre-
view, you’ll probably see major differences 

Figure 1: The 
three sections of 
the EPUB Export 

Options dialog box.
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in line breaks. Ebooks allow you to change 
the size of the text as well as the width of the 
page. This means that lines that broke at one 
point in the print layout (Figure 2) will break 
at other positions when the font or width of 
the page changes (Figure 3). This is a result 
of the text’s underlying HTML structure, and 
you’ll have to live with it. 

Master-Page Items.  The next thing to 
look at in the Digital Editions preview are the 
page numbers and headers (Figure 4). They’re 

gone (Figure 5)! Ebooks have no concept of 
pages: They’re just one long scroll of text. So 
InDesign discards page numbers, headers, 
and all other master-page items as part of the 
EPUB export.

Vertical Spacing. You may notice that 
your text is clumped together vertically even 
though it was spaced out on the page using 
paragraph returns (Figures 6 and 7, next page).

The EPUB format discards the space cre-
ated by multiple paragraph returns. (See, 
there is a reason why your InDesign instruc-
tor told you not to insert paragraph returns to 
add vertical space.) EPUB, like HTML, ignores 
more than one white space character, so 
multiple tabs, returns, spaces, and so on are 
treated as singles.

Figure 2: The line breaks for a print layout are fixed for that 
width of the text frame.

Figure 3: The line breaks for an EPUB change depending on 
the width of the ePUB page, size of the text, the font your 
audience chooses in the reader application .

Figure 4: The master page items as seen in the  
InDesign layout.

Figure 5: There are no master page items in the  
exported EPUB.

If you haven’t already installed 
Digital Editions, you can down-
load version 1.7 from http://
www.adobe.com/products/digi-
taleditions/ or you can download 
the latest (beta, but pretty stable) 
version, 1.8, from http://labs.
adobe.com/technologies/digi-
taleditions1-8/. Version 1.8 adds 
support for accessibility features, 
including high-contrast display 
and voice reading software.
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The EPUB also ignores the space created if 
you use open Object > Text Frame Options 
and set the Vertical Justification to Align: 
Justify. The paragraphs still clump up into a 
tight group.

The better way to add text between para-
graphs is to use Space Before or Space After 
(Figures 8 and 9), which does translate to an 
EPUB (usually).

Styles, Styles, Styles!
Many designers don’t use paragraph and 
character styles. While you may be able to 
slide by with that kind of behavior in print, 
ePubs demand that you fully format text with 
paragraph and character styles. These styles 
translate into the cascading style sheets 
that format the text. The styles also give you 
controls to break up text into 
sections, as well as to create a 
table of contents for navigating 
through the document. 

Figure 8: Use InDesign’s space before 
or space after commands to add some 
distance between paragraphs.

Figure 9: The EPUB usually honors 
the before and after spaces you 
applied to the paragraphs in 
InDesign.

Figure 6: In the print layout, paragraph 
returns add space between lines of text.

Figure 7: The EPUB discards the spaces created 
by the paragraph returns.

Start Sections with a Chapter Header. 
In a print layout, you break text into new 
pages by inserting page breaks or by speci-
fying that the paragraph starts on a new 
page. EPUBs ignore those instructions 
(Figure 10, next page). So what should you 
do if you want a line such as a chapter title 
or chapter number to start at the top of 
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the page when the reader scrolls through 
the document? These sections are actually 
smaller chunks of HTML that are combined 
together into the full EPUB.

First, apply a paragraph style to the line 
that you want to start the section. This gives 
you a way of identifying the line as the point 
where you want the text to break. You then 
choose File > Export to set the option as part 
of the Export Options dialog box.

Under the Contents section of the EPUB 
Export Options dialog box, select Break 
Document at Paragraph Style (Figure 11). 
Then choose the style for that element that 

you want to have start the section. This gives 
the instruction to break the text so that the 
element starts at the top of the reader’s page. 
Unfortunately, you can only have one style 
that starts a new section.

Create a Navigational Table  
of Contents.
You also use styles to create a navigation 
table of contents that lets the reader move 
quickly among sections of the book.

First, you apply the styles to the para-
graphs that should appear in the navigation 
table of contents; for instance, chapter head-
ers and subheads within the chapter. 

Next, you create a table of contents (TOC) 
Style that uses those elements. Go to Layout 
> Table of Contents Styles. Click New but-
ton to open the New Table of Contents Style 
dialog box (Figure 12). Name your style in 
the TOC Style field. Click the name of the 
style that you want to have as the naviga-
tion element and click the Add button. The 
style moves from the Other Styles area to 
the Include Paragraph Styles list. You don’t 

Figure 10: Chapter headers do not necessarily start at the 
top of pages in an EPUB.

Figure 11: Select a paragraph style that will be used to 
designate the start of a section.

Figure 12: The New Table of Contents Style dialog box 
lets you choose those styles that will be used to create the 
navigation points in your EPUB.
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Figure 15: Choose 
Rasterize First Page to 
convert the first page 
into a cover image for 
the exported EPUB.

have to worry about the Entry Style or Page 
Number or any other options here. Click OK 
and you’re done. Again, you don’t need to 
actually create a TOC in your document; you 
just need to define a style.

The next step is to turn that TOC style 
into the navigation element. In the Export 

dialog box (Figure 13), choose Use InDesign 
TOC Style and pick the name of the style you 
created in the previous step. This will cre-
ate the navigation list in the exported EPUB 
(Figure 14).

Creating a Cover Jacket
When an EPUB is displayed on the “book-
shelf” for e-readers such as the iPad or Kindle, 
a cover image helps people distinguish one 
book from another. You can turn the first 
page of your document into that cover image 

or use some other appropriate artwork.
In the General area of the EPUB Export 

Options dialog box, choose Rasterize First 
Page (Figure 15). This converts the first page 
of the book into a cover image (Figure 16). 
(It doesn’t change the first page in the actual 
EPUB, however.)

Alternatively, you can choose Use Existing 
Image File to select an external cover image.

Figure 13: Choose a TOC style to create the navigational list 
in the exported EPUB.

Figure 14: The navigation list, shown here on the left, 
appears in the exported EPUB.

Figure 16: On the left, the first page of the book has been 
rasterized into a cover. The book on the right was exported 
without a cover, so it has a generic design that looks much 
like all the other ePubs with cover images.
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Adding a Title and Author
Not all EPUB elements come from the Export 
dialog box. You set the title and author in 
the File > File Info dialog box. Choose it 
and then, under the Description tab, enter 
the Document Title and Author (Figure 17). 
These will now show up in the listing for the 
book in the Library of the EPUB reader.

Previewing the EPUB
As I mentioned at the beginning of this arti-
cle, the easiest way to preview the exported 

EPUB is with Adobe Digital Editions. But for 
the most reliable view, and one that can 
handle multimedia, you should preview 
exported ePubs on an actual tablet. Here are 
the steps for previewing on the Apple iPad 
and Kindle tablets.

Previewing on the Apple iPad
This one is easy. Just drag your EPUB over to 
your iTunes Library section and release. The 
EPUB is automatically added to the Books 
area of iTunes (Figure 18). Then sync the iPad 
to iTunes. The EPUB appears in the iBooks 
app on the iPad.

Previewing on a Kindle
Previewing on a Kindle is a little more com-
plicated, as the Kindle doesn’t use the plain 
EPUB format, but a variation of the .mobi 
ebook format. 

To convert the EPUB for a Kindle, first 
download the Kindle Previewer from 

Figure 17: Use the File Info Description area to add a 
document title and author for the EPUB. Figure 18: ePubs as they appear in iTunes.
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Amazon. Then open the EPUB with the 
Kindle Previewer. This validates the EPUB to 
make sure it meets the Kindle requirements 
and converts the EPUB into a .mobi file. A 
dialog box shows you the new file’s loca-
tion (Figure 19). Find the file and change the 
extension from .mobi to .azw. (Ignore any 
alerts that may show up about changing the 
file extension.)

Use the USB cable that came with the 
Kindle to mount the device on your com-
puter, then copy the .azw file into the 
Documents folder on the Kindle. The book 
will appear in the book list on the Kindle.

Creating a simple book, such as a novel or 
text-only document, is a great way to start 
learning the intricacies of EPUB. You’ll see 
how print elements are lost or modified and 
you’ll gain the skills needed to master this 
new future of publishing.

Sandee Cohen has both an iPad and Kindle, which she uses 
to teach creating EPUBS. She has more than 100 books and 
periodicals on her Kindle.

Figure 19: The Kindle Previewer compiles the EPUB and 
converts it into a .mobi file.

where creatives go 	
	 to know■
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